in Linux

First Post From Kubuntu

Kubuntu LogoI finally installed Kubuntu on my desktop machine at home at the weekend and I must say I am impressed so far. From my first experience with Red Hat 5.x in early 1999 (I’m guessing the version number from the date, I bought my first Linux book just before the exams of the first semester of my first year of Computer Science at QUB) I knew that *nix was real computing.

My sole piece of hardware back then was an original Pentium chip running at 100 MHz with 24 MB of RAM and approximately 1.2 GB of drive space (could be wrong about that figure.) I can vaguely remember the joy of partitioning the drive and getting Red Hat dual-booting with Win95. Getting X running wasn’t easy and involved scouring the manual and blindly executing various esoteric commands at the CLI, I don’t think I got the soundcard working and the thing that eventually got me to give up was not being able to use my winmodem (I couldn’t even afford to buy an external one!)

I kept coming back though. A few years later (possibly in 2002) I upgraded to an AMD 1800+ XP processor w/256 MB, initially running Windows ME (pirated, naturally.) This was when WinXP was still new and shiny and you couldn’t just copy someone else’s installation CD, but my mate Keith slipped me a copy of the infamous Devil’s Own release and that was me, even deeper into M$ territory. When I eventually got a broadband connection I was able to download a whole array of different distributions, but there was always something that stopped me making the jump.

My last major upgrade was to an AMD64 chip in 2004 and I thought it would be a prime opportunity to move to Linux as it had more to offer on the 64-bit front than Microsoft (XP64 was in beta at the time.) I think some multimedia aspect stopped me initially and it was back to XP32 for me. I wasn’t too fussed with XP64 either as there was a great lack of any 64-bit software.

Since then I’ve been playing about a lot with Slackware on older hardware (this site is running on it) and so I’m more familiar with core Linux operation, but I had problems with X on the unofficial 64-bit port of it and gave 64-bit Debian a go but couldn’t get OpenOffice to work. But things have been different this time around. The only hiccup in the installation was with the boot-loader trying to load things from the wrong drive numbers (mobo has 2 sets of SATA channels) and since the only thing that has given me stress has been establishing a VNC connection through a SSH tunnel from my XP workstation in the office, but that’s a post in itself!

I’ve been able to write and print documents, burn CDs and download and watch multimedia all with the minimum of effort. The package manager, Adept, is easy to use and Google has been able to satisfy most of my curiosities. I’ve found not having a root account a bit strange though…

Yep, I’ve got the Linux horn.

Write a Comment

Comment